import re
regex = re.compile(r"^wp-content/plugins/[^/]+/", flags=re.MULTILINE)
test_str = ("wp-content/plugins/event-tickets/tests/wpunit/Tribe/Tickets/Attendance_RSVP_TotalsTest.php\n\n"
"wp-content/plugins/the-events-calendar/tests/restv1/EventArchiveCest.php\n\n"
"wp-content/plugins/nodash/tests/restv1/EventArchiveCest.php\n\n"
"wp-content/plugins/-/tests/restv1/EventArchiveCest.php\n\n"
"wp-content/plugins/---/tests/restv1/EventArchiveCest.php\n\n"
"wp-content/plugins//tests/restv1/EventArchiveCest.php")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")