#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)`[^`]*`(*SKIP)(*F)|\R{2}"
Local $sString = "Some random text..." & @CRLF & _
"" & @CRLF & _
" text after break" & @CRLF & _
" haha text" & @CRLF & _
"" & @CRLF & _
" `Hey," & @CRLF & _
"" & @CRLF & _
" here is some text!" & @CRLF & _
"" & @CRLF & _
" and here is the end =)`" & @CRLF & _
"" & @CRLF & _
" here is text"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")