// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)`[^`]*`(*SKIP)(*F)|\R{2}").unwrap();
let string = "Some random text...
text after break
haha text
`Hey,
here is some text!
and here is the end =)`
here is text";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}