using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"`[^`]*`(*SKIP)(*F)|\R{2}";
string input = @"Some random text...
text after break
haha text
`Hey,
here is some text!
and here is the end =)`
here is text";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}