import re
regex = re.compile(r"([A-Z][a-z]+|[0-9]+|[A-Z]+?(?=[A-Z][a-z]|[0-9]|$))", flags=re.MULTILINE)
test_str = ("ThisIsATest\n"
"TestTest\n"
"ATMMachine\n"
"NewATM\n"
"NewATMMachine\n"
"TestTest123123\n"
"NewATM09\n"
"New99ATM\n"
"NewATMMachine09\n"
"99ATM")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")