re = /([A-Z][a-z]+|[0-9]+|[A-Z]+?(?=[A-Z][a-z]|[0-9]|$))/m
str = 'ThisIsATest
TestTest
ATMMachine
NewATM
NewATMMachine
TestTest123123
NewATM09
New99ATM
NewATMMachine09
99ATM'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end