using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Reference\s+(\d+)$";
string input = @"Pick Ticket 81091 Reference 109437
Issuing Date/Time 27/Jan/2022 10:19:10AM Status 35-Pick in Progress
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}