$re = '/Reference\s+(\d+)$/m';
$str = 'Pick Ticket 81091 Reference 109437
Issuing Date/Time 27/Jan/2022 10:19:10AM Status 35-Pick in Progress
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);