import re
regex = re.compile(r"Reference\s+(\d+)$", flags=re.MULTILINE)
test_str = ("Pick Ticket 81091 Reference 109437\n"
"Issuing Date/Time 27/Jan/2022 10:19:10AM Status 35-Pick in Progress\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")