package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)Reference\s+(\d+)$`)
var str = `Pick Ticket 81091 Reference 109437
Issuing Date/Time 27/Jan/2022 10:19:10AM Status 35-Pick in Progress
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}