# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(\d{3})\b.*:(?=\r?\n(?!\1)(\d{3})\b)/$0\n *** This value $2 ***/gm;t' <<< "111 is different from:
111 is different from:
123 is different from:
567."