import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\d{3})\\b.*:(?=\\r?\\n(?!\\1)(\\d{3})\\b)";
final String string = "111 is different from:\n"
+ "111 is different from:\n"
+ "123 is different from:\n"
+ "567.";
final String subst = "$0\\n *** This value $2 ***";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}