# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(\d{3})\b.*:(?=\r?\n(?!\1)(\d{3})\b)"
test_str = ("111 is different from:\n"
"111 is different from:\n"
"123 is different from:\n"
"567.")
subst = "$0\\n *** This value $2 ***"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.