$re = '/^(\d{3})\b.*:(?=\r?\n(?!\1)(\d{3})\b)/m';
$str = '111 is different from:
111 is different from:
123 is different from:
567.';
$subst = "$0\n *** This value $2 ***";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;