# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\s)+(?=[^[]*?\]\])/_/gm;t' <<< "this is the line with a [[filename01 as a wiki type link]] inside"