re = /(\s)+(?=[^[]*?\]\])/m
str = 'this is the line with a [[filename01 as a wiki type link]] inside'
subst = '_'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result