use strict;
my $str = 'this is the line with a [[filename01 as a wiki type link]] inside';
my $regex = qr/(\s)+(?=[^[]*?\]\])/mp;
my $subst = '_';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";