using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\s)+(?=[^[]*?\]\])";
string substitution = @"_";
string input = @"this is the line with a [[filename01 as a wiki type link]] inside";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}