using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*(['-]).*\1)(?!.*['-](?:[a-z]|$))(?!.*(?<=[^'-])[A-Z])[A-Z][A-Za-z'-]{0,31}$";
string input = @"Mc'Tiray-Jay
Mc'Tiray-JJay
Mc'Tiray-jJay
Mc'tiray-Jay
Mc'Tiray-Jay
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}