import re
regex = re.compile(r"^(?!.*(['-]).*\1)(?!.*['-](?:[a-z]|$))(?!.*(?<=[^'-])[A-Z])[A-Z][A-Za-z'-]{0,31}$", flags=re.MULTILINE)
test_str = ("Mc'Tiray-Jay\n"
"Mc'Tiray-JJay\n"
"Mc'Tiray-jJay\n"
"Mc'tiray-Jay\n"
"Mc'Tiray-Jay\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")