using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:<\s*([a-zA-Z]+)\s*.*?>)(?:.*)(<\s*\/*(\1)\s*>)";
string input = @" ""Some text <p>more text</p>"" {True}
""Some text < p >more text</p>"" {True}
""Some text <p style=""margin: 5px"">more text</p>"" {True}
""In range < 1 meter and > 1 cm"" {False}
""Must be >1m"" {False}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}