$re = '/(?:<\s*([a-zA-Z]+)\s*.*?>)(?:.*)(<\s*\/*(\1)\s*>)/m';
$str = ' "Some text <p>more text</p>" {True}
"Some text < p >more text</p>" {True}
"Some text <p style="margin: 5px">more text</p>" {True}
"In range < 1 meter and > 1 cm" {False}
"Must be >1m" {False}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);