import Foundation
let pattern = #"(?:<\s*([a-zA-Z]+)\s*.*?>)(?:.*)(<\s*\/*(\1)\s*>)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
"Some text <p>more text</p>" {True}
"Some text < p >more text</p>" {True}
"Some text <p style="margin: 5px">more text</p>" {True}
"In range < 1 meter and > 1 cm" {False}
"Must be >1m" {False}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)