re = /(?:<\s*([a-zA-Z]+)\s*.*?>)(?:.*)(<\s*\/*(\1)\s*>)/m
str = ' "Some text <p>more text</p>" {True}
"Some text < p >more text</p>" {True}
"Some text <p style="margin: 5px">more text</p>" {True}
"In range < 1 meter and > 1 cm" {False}
"Must be >1m" {False}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end