#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:.*\[.*\].*|.*(?!убит|отошел).*)$"
Local $sString = "Shoorik отошел" & @CRLF & _
"[G] Shoorik я отошел" & @CRLF & _
"текст должен выделяться" & @CRLF & _
"он был убит а" & @CRLF & _
"был убит 123" & @CRLF & _
"был убит" & @CRLF & _
"и этот текст тоже" & @CRLF & _
"[L] был убит" & @CRLF & _
"[G] просто текст " & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")