re = /^(?:.*\[.*\].*|.*(?!убит|отошел).*)$/m
str = 'Shoorik отошел
[G] Shoorik я отошел
текст должен выделяться
он был убит а
был убит 123
был убит
и этот текст тоже
[L] был убит
[G] просто текст
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end