using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:.*\[.*\].*|.*(?!убит|отошел).*)$";
string input = @"Shoorik отошел
[G] Shoorik я отошел
текст должен выделяться
он был убит а
был убит 123
был убит
и этот текст тоже
[L] был убит
[G] просто текст
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}