using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^!@""#$&'))*+,.\/:;<=>?^`{|}~ “”’%]{31,}";
string input = @"astringsmaller alongstringthatisgreaterthan32characterstomatch
alongstringthatisgreaterthan32characterstomatch astringsmaller
astring string alongstringthatisgreaterthan32 598931
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}