package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^!@"#$&'))*+,.\/:;<=>?^`{|}~ “”’%]{31,}`)
var str = `astringsmaller alongstringthatisgreaterthan32characterstomatch
alongstringthatisgreaterthan32characterstomatch astringsmaller
astring string alongstringthatisgreaterthan32 598931
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}