re = /[^!@"#$&'))*+,.\/:;<=>?^`{|}~ “”’%]{31,}/m
str = 'astringsmaller alongstringthatisgreaterthan32characterstomatch
alongstringthatisgreaterthan32characterstomatch astringsmaller
astring string alongstringthatisgreaterthan32 598931
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end