$re = '/[^!@"#$&\'))*+,.\/:;<=>?^`{|}~ “”’%]{31,}/m';
$str = 'astringsmaller alongstringthatisgreaterthan32characterstomatch
alongstringthatisgreaterthan32characterstomatch astringsmaller
astring string alongstringthatisgreaterthan32 598931
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);