#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(?<!\d)17(?!\d)"
Local $sString = "часть 179-а" & @CRLF & _
"часть 17-а" & @CRLF & _
"часть 17-2-б" & @CRLF & _
"часть 176" & @CRLF & _
"час17 а" & @CRLF & _
"часть 17К"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")