$re = '/(?<!\d)17(?!\d)/mi';
$str = 'часть 179-а
часть 17-а
часть 17-2-б
часть 176
час17 а
часть 17К';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);