const regex = /(?<!\d)17(?!\d)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!\\d)17(?!\\d)', 'gmi')
const str = `часть 179-а
часть 17-а
часть 17-2-б
часть 176
час17 а
часть 17К`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}