re = /(?<!\d)17(?!\d)/mi
str = 'часть 179-а
часть 17-а
часть 17-2-б
часть 176
час17 а
часть 17К'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end