import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([0-9]*\\.[0-9]*\\.[0-9]*\\.[0-9]*\\/[A-Za-z0-9]*).*(\\/.*)\\.php";
final String string = "127.0.0.1/project/folder/alfa.php\n"
+ "127.0.0.1/project/folder/subfolder/beta.php\n"
+ "127.0.0.1/folder/alfa.php";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}