$re = '/([0-9]*\.[0-9]*\.[0-9]*\.[0-9]*\/[A-Za-z0-9]*).*(\/.*)\.php/';
$str = '127.0.0.1/project/folder/alfa.php
127.0.0.1/project/folder/subfolder/beta.php
127.0.0.1/folder/alfa.php';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);