re = /([0-9]*\.[0-9]*\.[0-9]*\.[0-9]*\/[A-Za-z0-9]*).*(\/.*)\.php/
str = '127.0.0.1/project/folder/alfa.php
127.0.0.1/project/folder/subfolder/beta.php
127.0.0.1/folder/alfa.php'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end