import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^https?:\\/\\/[A-Za-z0-9:/.]+(?:([ ,;])https?:\\/\\/[A-Za-z0-9:/.]+(?:\\1[A-Za-z0-9:/.]+)*)?$";
final String string = "e.g this should match as it only uses one type of special character (semi-colon): \n\n"
+ "https://hello.com/example1;https://hello.com.com/example2;https://hello.com.com/example3\n\n"
+ "This should fail as it mixes two types of special characters (space and semi-colon)\n\n"
+ "https://hello.com/example1; https://hello.com.com/example2 ;https://hello.com.com/example3\n\n"
+ "https://hello.com/example1\n\n"
+ "test";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}