import re
regex = re.compile(r"^https?:\/\/[A-Za-z0-9:/.]+(?:([ ,;])https?:\/\/[A-Za-z0-9:/.]+(?:\1[A-Za-z0-9:/.]+)*)?$", flags=re.MULTILINE)
test_str = ("e.g this should match as it only uses one type of special character (semi-colon): \n\n"
"https://hello.com/example1;https://hello.com.com/example2;https://hello.com.com/example3\n\n"
"This should fail as it mixes two types of special characters (space and semi-colon)\n\n"
"https://hello.com/example1; https://hello.com.com/example2 ;https://hello.com.com/example3\n\n"
"https://hello.com/example1\n\n"
"test")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")