using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @" ?(Optional)? ?(ByVal|ByRef)? (\w*)(\(\))?(?:(?: As )(\w*))?(?: = )?([""]\w*[""])?";
string input = @"ByRef wbkRef() As Object, Optional ByVal strTetx As String = ""text"",Optional ByVal something ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}