$re = '/ ?(Optional)? ?(ByVal|ByRef)? (\w*)(\(\))?(?:(?: As )(\w*))?(?: = )?(["]\w*["])?/m';
$str = 'ByRef wbkRef() As Object, Optional ByVal strTetx As String = "text",Optional ByVal something ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);