re = / ?(Optional)? ?(ByVal|ByRef)? (\w*)(\(\))?(?:(?: As )(\w*))?(?: = )?(["]\w*["])?/m
str = 'ByRef wbkRef() As Object, Optional ByVal strTetx As String = "text",Optional ByVal something '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end