using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[x0100:xFFFF]";
string input = @"Fazıl Say - 2008 - 1001 Nights In The Harem\01 01. Allegro [Violin Concerto ('1001' Nights in the Harem) - live.mp3";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}