package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[x0100:xFFFF]`)
var str = `Fazıl Say - 2008 - 1001 Nights In The Harem\01 01. Allegro [Violin Concerto ('1001' Nights in the Harem) - live.mp3`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}