$re = '/[x0100:xFFFF]/m';
$str = 'Fazıl Say - 2008 - 1001 Nights In The Harem\\01 01. Allegro [Violin Concerto (\'1001\' Nights in the Harem) - live.mp3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);