const regex = /\bP(?=ARIS\b)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bP(?=ARIS\\b)', 'gm')
const str = `I'm a PARISIAN, I live in PARIS, my friend lives in PRAGUE. My father is coming to visit me in PARIS.
COMPARISON shouldn't match.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}