re = /\bP(?=ARIS\b)/m
str = 'I\'m a PARISIAN, I live in PARIS, my friend lives in PRAGUE. My father is coming to visit me in PARIS.
COMPARISON shouldn\'t match.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end