$re = '/\bP(?=ARIS\b)/m';
$str = 'I\'m a PARISIAN, I live in PARIS, my friend lives in PRAGUE. My father is coming to visit me in PARIS.
COMPARISON shouldn\'t match.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);