import re
regex = re.compile(r"\bP(?=ARIS\b)", flags=re.MULTILINE)
test_str = ("I'm a PARISIAN, I live in PARIS, my friend lives in PRAGUE. My father is coming to visit me in PARIS.\n"
"COMPARISON shouldn't match.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")